Interacting with GView

There are three main ways of interacting with the GView viewer: either through the menu system, through the birds eye view window, or through a number of different hot-keys. These are each described in more detail below.

Menus

menu_screenshot_1_7.png

The menus can be accessed after launching the GView viewer. The different options include:

  • File Menu
    • Open -> Opens a new project.
    • Export View As ... -> Save current view as an image.
    • Exit -> Exits the program.
  • View Menu
    • Enable Legend -> Enables or disables the legend. This will only have a visual effect if legends have been added.
    • Enable Labels -> Enables or disables the labels. This will only have a visual effect if labels have been added.
    • Enable Ruler -> Enables or disables the ruler.
    • Enable All -> Enables or disables the above elements.
    • Bird's Eye View -> Shows the Bird's Eye View dialog box.
    • Zoom
      • Zoom In -> Performs a contextual zoom in by 10%.
      • Zoom Out -> Performs a contextual zoom out by 10%.
      • Zoom (Percent) -> Sets the contextual zoom to the specific percent.
      • Custom ... -> Opens a dialog where the user can specify a specific zoom percent.
    • Scale
      • Scale In -> Performs a traditional scale in by 10%.
      • Scale Out -> Performs a traditional scale out by 10%.
      • Scale (Percent) -> Performs a traditional scale to the specific percent.
      • Custom ... -> Opens a dialog where the user can specify a specific scale percent.
    • Move
      • 0% -> Moves the view to the start of the genome.
      • 25% -> Moves the view 25% along the length of the genome.
      • 50% -> Moves the view 50% along the length of the genome.
      • 75% -> Moves the view 75% along the length of the genome.
      • 100% -> Moves the view 100% along the length of the genome.
      • Custom ... -> Opens a dialog where the user can specify a specific move location on the genome.
    • Layout
      • Linear -> Sets the layout of the genome to linear.
      • Circular -> Sets the layout of the genome to circular.
    • Fit Map to Screen -> Performs a traditional scale and centers the image such that it fits into window.
    • Full Screen -> Toggles full screen mode.
    • Quality
      • High -> Renders GView in high quality with normal visual effects.
      • Low -> Renders GView in low quality with very minimal visual effects.
  • Style Menu
    • Styles -> Allows for switching between loaded styles.
    • Style Editor -> Opens the Style Editor.
  • Help Menu
    • Viewer Usage -> Opens the viewer usage website.
    • Website -> Opens the GView website.
    • About -> Opens a dialog with some information about GView.

Bird's Eye View

birds_eye_view_1_7.png The Bird's Eye View dialog box can be accessed via the menu system, or via the key combination Ctrl + 'b'. It provides the user with a top-down view of the entire genome. The user can interact with the slider and buttons to change the scaling, which is reflected immediately in the main window. The transparent blue rectangle represents the camera viewing the genome. The camera can be dragged around the dialog or the user can double click within the dialog to center the camera on that location.

Hotkeys

GView can also be interacted with using the keyboard and mouse. The following is a list of actions available in the GView interactive mode.

Movement & Zooming
Hold Left Mouse Button + Move Mouse Panning movement.
Mouse Wheel
Ctrl + '+'
Ctrl + '-'
Perform a contextual zoom in/out.
Ctrl + '0' Reset the contextual zoom.
Ctrl + Mouse Wheel Performs a traditional zoom in/out.
(features and text get bigger or smaller, but do not spread out)
Ctrl + '<' Center the camera view on the first base in the genome.
Ctrl + '>' Center the camera view on the last base in the genome.
View
F11 Full Screen.
Ctrl + 'B' Shows the Bird's Eye View.
Ctrl + 'L' Turn display of legends on or off.
Ctrl + 'V' Set the zoom level so that the entire genome is visible.
Note This does not set the contextual zoom, but performs a traditional scaling to make the entire genome visible.
Ctrl + 'R' Resets the view. This will reset both the contextual zoom level and the scaling.
Ctrl + 'Q' Toggles the quality between high and low.
Interaction
Left Mouse Button Select a single item on the map.
Ctrl + Left Mouse Button Select multiple items on the map.
Middle Mouse Button Opens the website corresponding the selected feature.
Note This feature must be implemented in the GSS.
Ctrl + Alt + Left Mouse Button Opens the website corresponding the selected feature.
Note This feature must be implemented in the GSS.
Ctrl + 'E' Opens the style editor.
Ctrl + 'Z' Opens the custom contextual zoom dialog.
Ctrl + 'C' Opens the custom scale dialog.
Ctrl + 'M' Opens the custom move dialog.
File Management
Ctrl + 'O' Open a new GView map.
Ctrl + 'X' Export (save) the current view to a file.
 
Contact: Aaron Petkau, Eric Marinier, Matthew Stuart-Edwards at gview@phac-aspc.gc.ca